linux/3.3: build mdio_register_board_info into the kernel if PHYLIB is selected
[openwrt/openwrt.git] / target / linux / generic / patches-3.3 / 726-phy_rtl8366.patch
index 622a4327c6591a2385e4105497e360e601ad9fa3..190b28f45f82ea2d2668486a0af4f4c867a66906 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -162,6 +162,31 @@ config MDIO_OCTEON
+@@ -166,6 +166,31 @@ config MDIO_OCTEON
  
          If in doubt, say Y.
  
@@ -34,7 +34,7 @@
  config MICREL_KS8995MA
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY)     += ip17xx.o
+@@ -22,6 +22,9 @@ obj-$(CONFIG_IP17XX_PHY)     += ip17xx.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o