ebtables: fix compilation with GCC14
[openwrt/openwrt.git] / target / linux / generic / hack-6.1 / 430-mtk-bmt-support.patch
index 2a83f46e0ee8af837b130334259ee332df58351b..1e69ee644600ffd6da613551d1786ff78da5a498 100644 (file)
@@ -18,15 +18,15 @@ Subject: [PATCH] mtd/nand: add MediaTek NAND bad block managment table
 +      bool "Support MediaTek NAND Bad-block Management Table"
 +      default n
 +
- endmenu
- endmenu
+ config MTD_NAND_ECC_MXIC
+       bool "Macronix external hardware ECC engine"
+       depends on HAS_IOMEM
 --- a/drivers/mtd/nand/Makefile
 +++ b/drivers/mtd/nand/Makefile
-@@ -2,6 +2,7 @@
+@@ -3,6 +3,7 @@
  nandcore-objs := core.o bbt.o
  obj-$(CONFIG_MTD_NAND_CORE) += nandcore.o
+ obj-$(CONFIG_MTD_NAND_ECC_MEDIATEK) += ecc-mtk.o
 +obj-$(CONFIG_MTD_NAND_MTK_BMT)        += mtk_bmt.o mtk_bmt_v2.o mtk_bmt_bbt.o mtk_bmt_nmbm.o
  
  obj-y += onenand/