gemini: Bump to kernel v6.1
[openwrt/openwrt.git] / target / linux / gemini / Makefile
index 7c573c7c6d09fd8bd4214e2f672c36007e7b80bd..284d1247cb23f4b15fb086adb48ce76800ca3018 100644 (file)
@@ -1,19 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2009-2018 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=squashfs pci rtc usb dt gpio display
+FEATURES:=squashfs pci rtc usb dt gpio display ext4 rootfs-part boot-part
 CPU_TYPE:=fa526
-MAINTAINER:=Roman Yeryomin <roman@advem.lv>
+SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=5.15
+KERNEL_TESTING_PATCHVER:=6.1
 
 define Target/Description
        Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
@@ -24,9 +23,9 @@ KERNELNAME:=zImage dtbs
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-usb-core kmod-usb-fotg210 \
+       kmod-usb-fotg210 \
        kmod-usb-ledtrig-usbport \
-       kmod-leds-gpio kmod-ledtrig-heartbeat \
+       kmod-leds-gpio \
        kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))