gemini: Bump to kernel v6.1
[openwrt/openwrt.git] / target / linux / gemini / Makefile
index 14e786f8bb69fecd81aab71a0249b2c5f3d3cd25..284d1247cb23f4b15fb086adb48ce76800ca3018 100644 (file)
@@ -1,9 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2009-2018 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
@@ -11,8 +9,10 @@ BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
 FEATURES:=squashfs pci rtc usb dt gpio display ext4 rootfs-part boot-part
 CPU_TYPE:=fa526
+SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=4.19
+KERNEL_PATCHVER:=5.15
+KERNEL_TESTING_PATCHVER:=6.1
 
 define Target/Description
        Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
        kmod-usb-fotg210 \
        kmod-usb-ledtrig-usbport \
-       kmod-leds-gpio kmod-ledtrig-heartbeat \
+       kmod-leds-gpio \
        kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))