kernel: move b43 install function to broadcom.mk
[openwrt/openwrt.git] / target / linux / brcm63xx / dts / fast2704n.dts
index 217ef12d7cbdc6ecf8de854edf618f04e2bfba52..33842cc646fdbfd12c6e7f23ae256bd539cc677d 100644 (file)
@@ -9,35 +9,39 @@
        compatible = "sagem,f@st2704n", "brcm,bcm6318";
 
        chosen {
-               bootargs = "root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
                stdout-path = "serial0:115200n8";
        };
 
-       gpio-keys-polled {
+       keys {
                compatible = "gpio-keys-polled";
                #address-cells = <1>;
                #size-cells = <0>;
                poll-interval = <20>;
-               debounce-interval = <60>;
 
                wlan {
                        label = "wlan";
                        gpios = <&pinctrl 1 0>;
                        linux,code = <KEY_WLAN>;
+                       debounce-interval = <60>;
                };
+
                wps {
                        label = "wps";
                        gpios = <&pinctrl 33 1>;
                        linux,code = <KEY_WPS_BUTTON>;
+                       debounce-interval = <60>;
                };
+
                reset {
                        label = "reset";
                        gpios = <&pinctrl 34 1>;
                        linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
                };
        };
 
-       gpio-leds {
+       leds {
                compatible = "gpio-leds";
 
                wps_green {
                #address-cells = <1>;
                #size-cells = <1>;
 
-               linux,part-probe = "bcm63xxpart";
-
-               cfe@0 {
-                       reg = <0x000000 0x010000>;
-                       label = "cfe";
-                       read-only;
-               };
-
-               linux@10000 {
-                       reg = <0x010000 0x7e0000>;
-                       label = "linux";
-               };
-
-               nvram@7f0000 {
-                       reg = <0x7f0000 0x010000>;
-                       label = "nvram";
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       cfe@0 {
+                               reg = <0x000000 0x010000>;
+                               label = "cfe";
+                               read-only;
+                       };
+
+                       linux@10000 {
+                               reg = <0x010000 0x7e0000>;
+                               label = "linux";
+                               compatible = "brcm,bcm963xx-imagetag";
+                       };
+
+                       nvram@7f0000 {
+                               reg = <0x7f0000 0x010000>;
+                               label = "nvram";
+                       };
                };
        };
 };