kernel: move b43 install function to broadcom.mk
[openwrt/openwrt.git] / target / linux / brcm63xx / dts / dsl-274xb-c.dts
index 29ae125479664815a82cb0e6c1a7cac594c12cd7..6897378fe80fab865db25aaf3f13c0de06c04b64 100644 (file)
@@ -8,43 +8,48 @@
        model = "D-Link DSL-2740B/DSL-2741B rev C2/3";
        compatible = "d-link,dsl-274xb-c2", "brcm,bcm6358";
 
-       gpio-keys-polled {
+       chosen {
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       keys {
                compatible = "gpio-keys-polled";
                #address-cells = <1>;
                #size-cells = <0>;
                poll-interval = <20>;
-               debounce-interval = <60>;
 
                reset {
                        label = "reset";
-                       gpios = <&gpio1 2 1>;
+                       gpios = <&pinctrl 34 1>;
                        linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
                };
        };
 
-       gpio-leds {
+       leds {
                compatible = "gpio-leds";
 
                inet_green {
                        label = "dsl-274xb:green:internet";
-                       gpios = <&gpio0 2 0>;
+                       gpios = <&pinctrl 2 0>;
                };
                power_red {
                        label = "dsl-274xb:red:power";
-                       gpios = <&gpio0 4 1>;
+                       gpios = <&pinctrl 4 1>;
                };
                power_green {
                        label = "dsl-274xb:green:power";
-                       gpios = <&gpio0 5 1>;
+                       gpios = <&pinctrl 5 1>;
                        default-state = "on";
                };
                dsl_green {
                        label = "dsl-274xb:green:adsl";
-                       gpios = <&gpio0 9 1>;
+                       gpios = <&pinctrl 9 1>;
                };
                inet_red {
                        label = "dsl-274xb:red:internet";
-                       gpios = <&gpio0 10 0>;
+                       gpios = <&pinctrl 10 0>;
                };
        };
 };
 &pflash {
        status = "ok";
 
-       linux,part-probe = "bcm63xxpart";
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
 
-       cfe@0 {
-               label = "CFE";
-               reg = <0x000000 0x010000>;
-               read-only;
-       };
+               cfe@0 {
+                       label = "CFE";
+                       reg = <0x000000 0x010000>;
+                       read-only;
+               };
 
-       linux@10000 {
-               label = "linux";
-               reg = <0x010000 0x3e0000>;
-       };
+               linux@10000 {
+                       label = "linux";
+                       reg = <0x010000 0x3e0000>;
+                       compatible = "brcm,bcm963xx-imagetag";
+               };
 
-       nvram@3f0000 {
-               label = "nvram";
-               reg = <0x3f0000 0x010000>;
+               nvram@3f0000 {
+                       label = "nvram";
+                       reg = <0x3f0000 0x010000>;
+               };
        };
 };
+
+&uart0 {
+       status = "ok";
+};