kernel: move b43 install function to broadcom.mk
[openwrt/openwrt.git] / target / linux / brcm63xx / dts / bcm96338GW.dts
index d7af9ef6510254977c7507a54c4a2d3fab4f1ef0..92363ec3a195ec6f6a12899d01d57a64e923db30 100644 (file)
@@ -8,7 +8,12 @@
        model = "Broadcom BCM96338GW reference board";
        compatible = "brcm,bcm96338gw", "brcm,bcm6338";
 
-       gpio-leds {
+       chosen {
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       leds {
                compatible = "gpio-leds";
 
                power_green {
                };
        };
 };
+
+&pflash {
+       status = "ok";
+
+       partitions {
+               compatible = "brcm,bcm963xx-cfe-nor-partitions";
+       };
+};
+
+&uart0 {
+       status = "ok";
+};