kernel: move b43 install function to broadcom.mk
[openwrt/openwrt.git] / target / linux / brcm63xx / dts / bcm96338GW.dts
index 7815962cd8d5f679cf7c7433bbcb7bd3113b4711..92363ec3a195ec6f6a12899d01d57a64e923db30 100644 (file)
@@ -9,10 +9,11 @@
        compatible = "brcm,bcm96338gw", "brcm,bcm6338";
 
        chosen {
-               bootargs = "root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
        };
 
-       gpio-leds {
+       leds {
                compatible = "gpio-leds";
 
                power_green {
 &pflash {
        status = "ok";
 
-       linux,part-probe = "bcm63xxpart";
+       partitions {
+               compatible = "brcm,bcm963xx-cfe-nor-partitions";
+       };
+};
+
+&uart0 {
+       status = "ok";
 };