kernel: move b43 install function to broadcom.mk
[openwrt/openwrt.git] / target / linux / brcm63xx / dts / ad1018-nor.dts
index 7a630a1856481d1a51ace0bde41659d25a3ee911..36899a4cc0e65b1c46b54bc0c364bccad83a262f 100644 (file)
@@ -9,34 +9,37 @@
        compatible = "sercomm,ad1018-nor", "brcm,bcm6328";
 
        chosen {
-               bootargs = "root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
                stdout-path = "serial0:115200n8";
        };
 
-       gpio-keys-polled {
+       keys {
                compatible = "gpio-keys-polled";
                #address-cells = <1>;
                #size-cells = <0>;
                poll-interval = <20>;
-               debounce-interval = <60>;
 
                wps {
                        label = "wps";
                        gpios = <&pinctrl 24 1>;
                        linux,code = <KEY_WPS_BUTTON>;
+                       debounce-interval = <60>;
                };
+
                wifi {
                        label = "wifi";
                        gpios = <&pinctrl 25 1>;
                        linux,code = <KEY_WLAN>;
+                       debounce-interval = <60>;
                };
+
                reset {
                        label = "reset";
                        gpios = <&pinctrl 31 1>;
                        linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
                };
        };
-
 };
 
 &pinctrl {
                #address-cells = <1>;
                #size-cells = <1>;
 
-               linux,part-probe = "bcm63xxpart";
+               partitions {
+                       compatible = "brcm,bcm963xx-cfe-nor-partitions";
+               };
        };
 };