build: get rid of host.mk
[openwrt/staging/yousong.git] / target / linux / brcm2708 / Makefile
index 9d0d921738c81475a5785842ff081f82bf3f305e..8dc923907d23f7d694c54ee395ed66d4811b5602 100644 (file)
@@ -5,7 +5,6 @@
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/host.mk
 
 ARCH:=arm
 BOARD:=brcm2708
@@ -14,16 +13,16 @@ FEATURES:=ext4 audio usb usbgadget display gpio fpu
 MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 SUBTARGETS:=bcm2708 bcm2709 bcm2710
 
-KERNEL_PATCHVER:=4.4
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build firmware image for Broadcom BCM27xx SoC devices.
        Currently produces SD Card image for Raspberry Pi.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+
 KERNELNAME:=Image dtbs
 
 $(eval $(call BuildTarget))