fix serial flash support (#6442)
[openwrt/openwrt.git] / target / linux / brcm-2.4 / patches / 004-flash.patch
index f34efb0146be0c2db9bbfc62f26bac5ab2ed50aa..7de8a82eb6ae9f9de2e95f8a6e40680561f4825f 100644 (file)
@@ -1,3 +1,13 @@
+--- a/arch/mips/bcm947xx/Makefile      
++++ b/arch/mips/bcm947xx/Makefile      
+@@ -11,6 +11,7 @@
+ obj-y         := prom.o setup.o time.o sbmips.o gpio.o
+ obj-y         += nvram.o nvram_linux.o cfe_env.o hndpmu.o
+ obj-y         += sbutils.o utils.o bcmsrom.o hndchipc.o
++obj-y         += sflash.o
+ obj-$(CONFIG_PCI) += sbpci.o pcibios.o
+ obj-y                 += export.o
 --- a/drivers/mtd/devices/Config.in
 +++ b/drivers/mtd/devices/Config.in
 @@ -5,6 +5,7 @@