WIP: bcm63xx: SFR NB6V support
[openwrt/staging/noltari.git] / target / linux / bcm63xx / image / bcm63xx_nand.mk
index 81c328b712ec0bb31d115cbce87c31b9c5a38d10..458a38ca350a2ef0f1a58666e6e3f335a93106ff 100644 (file)
@@ -203,3 +203,20 @@ define Device/sercomm_h500-s-vfes
   SERCOMM_VERSION := 1001
 endef
 TARGET_DEVICES += sercomm_h500-s-vfes
+
+### SFR ###
+define Device/sfr_neufbox-6v-foxconn-r0
+  $(Device/bcm63xx-nand)
+  DEVICE_VENDOR := SFR
+  DEVICE_MODEL := Neufbox 6V
+  CHIP_ID := 63268
+  SOC := bcm63168
+  CFE_RAM_FILE := sfr,neufbox-6v-foxconn-r0/cferam.000
+  CFE_RAM_JFFS2_NAME := cferam.000
+  BLOCKSIZE := 16k
+  PAGESIZE := 512
+  DEVICE_PACKAGES += $(USB2_PACKAGES)
+  CFE_WFI_FLASH_TYPE := 2
+  CFE_WFI_VERSION := 0x5731
+endef
+TARGET_DEVICES += sfr_neufbox-6v-foxconn-r0