bcm4908: add testing support for kernel 6.1
[openwrt/staging/hauke.git] / target / linux / bcm4908 / Makefile
index 5bee66fe2b429d403a297663f061dc7d892943d6..45b4a62f2f5a8a0b30595acefc4d81d8853d28ae 100644 (file)
@@ -5,12 +5,12 @@ include $(TOPDIR)/rules.mk
 ARCH:=aarch64
 BOARD:=bcm4908
 BOARDNAME:=Broadcom BCM4908 (ARMv8A CPUs Brahma-B53)
-FEATURES:=squashfs nand usb pci pcie gpio source-only
+FEATURES:=squashfs nand usb gpio
 CPU_TYPE:=cortex-a53
 SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=5.4
-KERNEL_TESTING_PATCHVER:=5.4
+KERNEL_PATCHVER:=5.15
+KERNEL_TESTING_PATCHVER:=6.1
 
 define Target/Description
        Build firmware images for Broadcom BCM4908 SoC family routers.
@@ -20,6 +20,10 @@ include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=Image dtbs
 
-DEFAULT_PACKAGES += kmod-usb-ohci kmod-usb2 kmod-usb3
+DEFAULT_PACKAGES += \
+       bcm4908img fdt-utils uboot-envtools \
+       kmod-gpio-button-hotplug \
+       kmod-usb-ohci kmod-usb2 kmod-usb3 \
+       kmod-usb-ledtrig-usbport
 
 $(eval $(call BuildTarget))