atheros: remove odd board check during image build
[openwrt/openwrt.git] / target / linux / atheros / image / Makefile
index 7b035a6a8bb2f767ded1dec8ad6ad3f74ec1f4cb..86f2d44bfecb36eb49be9a6422fc7dd631be633b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/BuildKernel
-       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
        gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
-       dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
-       dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.gz bs=65536 conv=sync
+       dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
+       dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.gz bs=65536 conv=sync
 endef
 
 define Image/Build/squashfs
@@ -21,27 +21,40 @@ endef
 
 define Image/Build
        $(call Image/Build/$(1))
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
-
-       echo -en "kernel\t\t0x01\t0xBE030000\t0x" > $(BIN_DIR)/ls5-parts
-       echo -en "$(shell printf "%08X\n" $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c))" >> $(BIN_DIR)/ls5-parts
-       echo -e "\t0x80041000\t0x80041000\t$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" >> $(BIN_DIR)/ls5-parts 
-       echo -en "rootfs\t\t0x02\t0x" >> $(BIN_DIR)/ls5-parts
-       echo -en "$(shell printf "%08X\n" $(shell expr $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) + 3187867648 ) )" >> $(BIN_DIR)/ls5-parts
-       echo -en "\t0x$(shell printf "%08X\n" $(shell expr 3735552 - $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) ) )" >> $(BIN_DIR)/ls5-parts
-       echo -e "\t0x00000000\t0x00000000\t$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" >> $(BIN_DIR)/ls5-parts
-       
-       echo -en "kernel\t\t0x01\t0xBFC30000\t0x" > $(BIN_DIR)/ls2-parts
-       echo -en "$(shell printf "%08X\n" $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c))" >> $(BIN_DIR)/ls2-parts
-       echo -e "\t0x80041000\t0x80041000\t$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma" >> $(BIN_DIR)/ls2-parts
-       echo -en "rootfs\t\t0x02\t0x" >> $(BIN_DIR)/ls2-parts
-       echo -en "$(shell printf "%08X\n" $(shell expr $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) + 3217227776 ) )" >> $(BIN_DIR)/ls2-parts
-       echo -en "\t0x$(shell printf "%08X\n" $(shell expr 3866624 - $(shell cat $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma | wc -c) ) )" >> $(BIN_DIR)/ls2-parts
-       echo -e "\t0x00000000\t0x00000000\t$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)" >> $(BIN_DIR)/ls2-parts
-
-       $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls2-parts -v XS2.ar2316.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
-       $(STAGING_DIR_HOST)/bin/mkfwimage -i $(BIN_DIR)/ls5-parts -v XS5.ar2313.OpenWRT -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin
-       rm $(BIN_DIR)/ls2-parts $(BIN_DIR)/ls5-parts
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+
+       -$(STAGING_DIR_HOST)/bin/mkfwimage \
+               -B XS2 -v XS2.ar2316.OpenWrt.$(REVISION) \
+               -k $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma \
+               -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+               -o $(BIN_DIR)/$(IMG_PREFIX)-ubnt2-$(1).bin
+
+       -$(STAGING_DIR_HOST)/bin/mkfwimage \
+               -B XS5 -v XS5.ar2313.OpenWrt.$(REVISION) \
+               -k $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma \
+               -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+               -o $(BIN_DIR)/$(IMG_PREFIX)-ubnt5-$(1).bin
+
+       -$(STAGING_DIR_HOST)/bin/mkfwimage \
+               -B XS2-8 -v XS2.ar2316.OpenWrt.$(REVISION) \
+               -k $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma \
+               -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+               -o $(BIN_DIR)/$(IMG_PREFIX)-ubnt2-pico2-$(1).bin
+
+       -$(STAGING_DIR_HOST)/bin/mkmylofw -B np25g \
+               -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz  \
+               -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+               $(BIN_DIR)/$(IMG_PREFIX)-np25g-$(1).bin
+
+       -$(STAGING_DIR_HOST)/bin/mkmylofw -B wpe53g \
+               -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz  \
+               -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+               $(BIN_DIR)/$(IMG_PREFIX)-wpe53g-$(1).bin
+
+       -sh $(TOPDIR)/scripts/combined-image.sh \
+               "$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma" \
+               "$(BIN_DIR)/$(IMG_PREFIX)-root.$(1)" \
+               "$(BIN_DIR)/$(IMG_PREFIX)-combined.$(1).img"
 endef
 
 $(eval $(call BuildImage))