ath79: Do not build buffalo_whr-g301n by default
[openwrt/staging/luka.git] / target / linux / ath79 / image / tiny.mk
index 54b20b60893cdf87c3d45c78a27423790bd74662..9f4f89bd9a658c5a2473a4fed31be6a43a467f4e 100644 (file)
@@ -7,11 +7,12 @@ define Device/buffalo_whr-g301n
   IMAGE_SIZE := 3712k
   IMAGES += factory.bin tftp.bin
   IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
-       pad-rootfs | check-size $$$$(IMAGE_SIZE)
+       pad-rootfs | check-size
   IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WHR-G301N 1.99 | \
        buffalo-tag WHR-G301N 3
   IMAGE/tftp.bin := $$(IMAGE/default) | buffalo-tftp-header
   SUPPORTED_DEVICES += whr-g301n
+  DEFAULT := n
 endef
 TARGET_DEVICES += buffalo_whr-g301n
 
@@ -25,7 +26,7 @@ define Device/dlink_dir-615-e4
   IMAGES += factory.bin
   IMAGE/default := append-kernel | append-rootfs | pad-rootfs
   IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
-       check-size $$$$(IMAGE_SIZE)
+       check-size
   IMAGE/factory.bin := $$(IMAGE/default) | \
        check-size $$$$(FACTORY_IMAGE_SIZE) | pad-to $$$$(FACTORY_IMAGE_SIZE) | \
        append-string "AP99-AR7240-RT-091105-05"