ath79: Add support for Ubiquiti NanoBeam AC Gen1 XC
[openwrt/staging/dedeckeh.git] / target / linux / ath79 / image / generic-ubnt.mk
index bb5eaa5458bc8af90dffac3fa28359cc957786d7..9470adf48b135fea5eb73cf246a69da3b2e7f057 100644 (file)
@@ -246,6 +246,15 @@ define Device/ubnt_nanobeam-ac-gen2
 endef
 TARGET_DEVICES += ubnt_nanobeam-ac-gen2
 
+define Device/ubnt_nanobeam-ac-xc
+  $(Device/ubnt-xc)
+  SOC := qca9558
+  DEVICE_MODEL := NanoBeam AC
+  DEVICE_VARIANT := Gen1 (XC)
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct rssileds
+endef
+TARGET_DEVICES += ubnt_nanobeam-ac-xc
+
 define Device/ubnt_nanobridge-m
   $(Device/ubnt-xm)
   SOC := ar7241