uboot-at91: fix DTC command not found.
[openwrt/staging/hauke.git] / target / linux / at91 / image / sama5.mk
index 1c779ca32726f73844c8d6480a88ff09d9dd48df..fd7a53421eb4f0895e1c615d5fc840a89196e0b8 100644 (file)
@@ -1,3 +1,44 @@
+AT91_SD_BOOT_PARTSIZE:=64
+FAT32_BLOCK_SIZE:=1024
+FAT32_BLOCKS:=$(shell echo \
+  $$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+
+define Build/at91-sdcard
+  $(if $(findstring ext4,$@), \
+  rm -f $@.boot
+  mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+
+  mcopy -i $@.boot $(KDIR)/zImage ::zImage
+
+  $(foreach dts,$(DEVICE_DTS), \
+     mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
+        ::$(dts).dtb)
+
+  mcopy -i $@.boot \
+    $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
+    ::u-boot.bin
+
+  mcopy -i $@.boot \
+    $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
+    ::BOOT.bin
+
+  ./gen_at91_sdcard_img.sh \
+      $@.img \
+      $@.boot \
+      $(KDIR)/root.ext4 \
+      $(AT91_SD_BOOT_PARTSIZE) \
+      $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+
+  gzip -nc9 $@.img > $@
+
+  rm -f $@.img $@.boot )
+endef
+
+define Device/evaluation-sdimage
+  IMAGES += sdcard.img.gz
+  IMAGE/sdcard.img.gz := at91-sdcard
+endef
+
 define Device/default-nand
   BLOCKSIZE := 128k
   PAGESIZE := 2048
@@ -9,6 +50,7 @@ define Device/at91-sama5d3_xplained
   $(Device/evaluation-dtb)
   DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
   KERNEL_SIZE := 6144k
+  $(Device/evaluation-sdimage)
 endef
 TARGET_DEVICES += at91-sama5d3_xplained
 
@@ -16,6 +58,7 @@ define Device/at91-sama5d2_xplained
   $(Device/evaluation-dtb)
   DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
   KERNEL_SIZE := 6144k
+  $(Device/evaluation-sdimage)
 endef
 TARGET_DEVICES += at91-sama5d2_xplained
 
@@ -27,5 +70,32 @@ define Device/at91-sama5d4_xplained
   PAGESIZE := 4096
   SUBPAGESIZE := 2048
   MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
+  $(Device/evaluation-sdimage)
 endef
 TARGET_DEVICES += at91-sama5d4_xplained
+
+define Device/at91-sama5d27_som1_ek
+  $(Device/evaluation-dtb)
+  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
+  KERNEL_SIZE := 6144k
+  $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d27_som1_ek
+
+ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+  define Device/wb50n
+    $(Device/evaluation-fit)
+    DEVICE_TITLE := Laird WB50N
+    DEVICE_PACKAGES := \
+         kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
+         kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
+         kmod-leds-gpio
+    BLOCKSIZE := 128k
+    PAGESIZE := 2048
+    SUBPAGESIZE := 2048
+    MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+  endef
+  TARGET_DEVICES += wb50n
+ endif
+endif