AT91: Add flexibity board support
[openwrt/staging/jow.git] / target / linux / at91 / Makefile
index 355f4418da1624b9182999913805d608f1a1c500..1d65d750d9e27f3f57faa1fa725ebe3bfbb582a1 100644 (file)
@@ -8,11 +8,13 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+SUBTARGETS:=netus tqma9263 flexibity
 
-LINUX_VERSION:=2.6.34.1
+LINUX_VERSION:=2.6.38.8
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
@@ -20,8 +22,4 @@ include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+= kmod-usb-ohci
 KERNELNAME:="uImage"
 
-define Target/Description
-       Build firmware images for Acmesystems NetusG20 board
-endef
-
 $(eval $(call BuildTarget))