ar71xx: move Zbtlink ZBT-WE1526 to generic build target
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index 2ad058e8452ebb338d5ca367d3f7d486170b7731..33db5865bfa8ed504a9aa707adf163a38d7658ca 100644 (file)
@@ -825,3 +825,24 @@ define Device/wpj558
   IMAGE_SIZE := 16128k
 endef
 TARGET_DEVICES += wpj558
+
+define Device/wpj563
+  DEVICE_TITLE := Compex WPJ563 (16MB flash)
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+  BOARDNAME := WPJ563
+  MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
+  IMAGE_SIZE := 16128k
+endef
+TARGET_DEVICES += wpj563
+
+define Device/zbt-we1526
+  DEVICE_TITLE := Zbtlink ZBT-WE1526
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+  BOARDNAME := ZBT-WE1526
+  IMAGE_SIZE := 16000k
+  KERNEL_SIZE := 1472k
+  ROOTFS_SIZE := 14528k
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
+  IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += zbt-we1526