ar71xx: create profile and build image for the OpenMesh OM5P-AC board
[openwrt/staging/lynxis.git] / target / linux / ar71xx / generic / profiles / openmesh.mk
index 2f33d83c3e60d7b3688864682d87c8bce1c03ba5..0873ac53066f0fef7d8ebae36b6d201eb7136db1 100644 (file)
@@ -16,6 +16,28 @@ endef
 
 $(eval $(call Profile,OM2P))
 
+define Profile/OM5P
+       NAME:=OpenMesh OM5P/OM5P-AN
+       PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/OM5P/Description
+       Package set optimized for the OpenMesh OM5P/OM5P-AN.
+endef
+
+$(eval $(call Profile,OM5P))
+
+define Profile/OM5PAC
+       NAME:=OpenMesh OM5P-AC
+       PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
+endef
+
+define Profile/OM5PAC/Description
+       Package set optimized for the OpenMesh OM5P-AC.
+endef
+
+$(eval $(call Profile,OM5PAC))
+
 define Profile/MR600
         NAME:=OpenMesh MR600
         PACKAGES:=kmod-ath9k om-watchdog
@@ -27,9 +49,31 @@ endef
 
 $(eval $(call Profile,MR600))
 
+define Profile/MR900
+        NAME:=OpenMesh MR900/MR900v2
+        PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/MR900/Description
+        Package set optimized for the OpenMesh MR900/MR900v2.
+endef
+
+$(eval $(call Profile,MR900))
+
+define Profile/MR1750
+        NAME:=OpenMesh MR1750
+        PACKAGES:=kmod-ath9k kmod-ath10k
+endef
+
+define Profile/MR1750/Description
+        Package set optimized for the OpenMesh MR1750.
+endef
+
+$(eval $(call Profile,MR1750))
+
 define Profile/OPENMESH
        NAME:=OpenMesh products
-       PACKAGES:=kmod-ath9k om-watchdog
+       PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
 endef
 
 define Profile/OPENMESH/Description