ar71xx: use kernel 4.9 by default
[openwrt/staging/stintel.git] / target / linux / ar71xx / Makefile
index 893742600762f95d709969f8df279230fc1864a3..6d5b4c52b3e4ed44d907c2ddfa3ac14724b965bd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR913x
-FEATURES:=squashfs tgz
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=usbgadget
+CPU_TYPE:=24kc
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=2.6.28.7
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-madwifi kmod-gpio-leds
-
-define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x based boards
-endef
+DEFAULT_PACKAGES += \
+       kmod-gpio-button-hotplug swconfig \
+       kmod-ath9k wpad-mini uboot-envtools
 
 $(eval $(call BuildTarget))