treewide: use wpad-basic for not small flash targets
[openwrt/staging/lynxis.git] / target / linux / ar71xx / Makefile
index b0b096a2fe449dda8fb0543dbb97a6e4625fe3b1..047d34184e1e7f121eff8796cf8d7f852f9477cf 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,21 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-SUBTARGETS:=generic nand
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=usbgadget
+CPU_TYPE:=24kc
+SUBTARGETS:=generic tiny nand mikrotik
 
-LINUX_VERSION:=2.6.37.1
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-buttons kmod-button-hotplug swconfig
-
-define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x based boards.
-endef
+       kmod-gpio-button-hotplug swconfig \
+       kmod-ath9k uboot-envtools
 
 $(eval $(call BuildTarget))