treewide: use wpad-basic for not small flash targets
[openwrt/staging/lynxis.git] / target / linux / ar71xx / Makefile
index 30610f8c6f4d32d75bb5099c27512a5d8e1e1cb3..047d34184e1e7f121eff8796cf8d7f852f9477cf 100644 (file)
@@ -9,20 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-SUBTARGETS:=generic nand
+FEATURES:=usbgadget
+CPU_TYPE:=24kc
+SUBTARGETS:=generic tiny nand mikrotik
 
-LINUX_VERSION:=3.2.12
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug kmod-wdt-ath79 swconfig \
-       kmod-ath9k wpad-mini uboot-envtools
-
-define Target/Description
-       Build firmware images for Atheros AR7xxx/AR9xxx based boards.
-endef
+       kmod-gpio-button-hotplug swconfig \
+       kmod-ath9k uboot-envtools
 
 $(eval $(call BuildTarget))