brcm2708: fix renamed definition (FS#2265)
[openwrt/openwrt.git] / target / linux / adm5120 / Makefile
index c7c66705a3d6dc8858729d653c2080e79d2283eb..fbfaf6d23cf5537ead98a056e31791d624970e47 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007,2008 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
-BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.24
-SUBTARGETS:=router_le router_be
+BOARDNAME:=Infineon/ADMtek ADM5120
+FEATURES:=low_mem small_flash source-only
+SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
+KERNEL_PATCHVER:=3.18
+
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-keys-polled kmod-button-hotplug \
+                   kmod-leds-gpio kmod-ledtrig-adm5120-switch
 
 $(eval $(call BuildTarget))