add prereq checks for target/linux/* and target/image/*, check for fdisk for the...
[openwrt/staging/jow.git] / target / image / x86 / Makefile
index 9b983ad603a82201d89f964bcd7c3a84ce59af3f..d3bbe045be067b5609b2c3479c52d6b68f71fb15 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
-")) # fix vim's broken syntax highlighting
+#")) # fix vim's broken syntax highlighting
 
 
 ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
@@ -54,5 +54,8 @@ define Image/Build
        cp $(LINUX_DIR)/arch/i386/boot/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
 endef
 
-
 $(eval $(call BuildImage))
+
+$(eval $(call RequireCommand,fdisk, \
+       Please install fdisk \
+))