iwinfo: update to latest Git HEAD
[openwrt/staging/rmilecki.git] / package / network / utils / iwinfo / Makefile
index 8d50d289e781e951010c53c7a342b4521ac1f02a..cee7253a3aa9b6b287cad8b1bc5ca5e9ef02e191 100644 (file)
@@ -7,14 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_VERSION:=2016-09-21
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL=$(LEDE_GIT)/project/iwinfo.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fd9e17be0c43bd6b8df5371f0b353747bc563874
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE_URL=$(PROJECT_GIT)/project/iwinfo.git
+PKG_SOURCE_DATE:=2019-10-16
+PKG_SOURCE_VERSION:=07315b6fdb2566a8626d8a1e4de76eb30456fe17
+PKG_MIRROR_HASH:=924914a51b8a668779e41dc2f40adfc1ae51846ea8b013de3e45999b4d04eecd
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=GPL-2.0
 
@@ -24,7 +23,6 @@ PKG_CONFIG_DEPENDS := \
        CONFIG_PACKAGE_kmod-brcm-wl \
        CONFIG_PACKAGE_kmod-brcm-wl-mini \
        CONFIG_PACKAGE_kmod-brcm-wl-mimo \
-       CONFIG_PACKAGE_kmod-madwifi \
        CONFIG_PACKAGE_kmod-cfg80211
 
 include $(INCLUDE_DIR)/package.mk
@@ -34,13 +32,13 @@ define Package/libiwinfo
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Generalized Wireless Information Library (iwinfo)
-  DEPENDS:=+PACKAGE_kmod-cfg80211:libnl-tiny +libuci
-  ABI_VERSION:=$(PKG_RELEASE)
+  DEPENDS:=+PACKAGE_kmod-cfg80211:libnl-tiny +libuci +libubus
+  ABI_VERSION:=20181126
 endef
 
 define Package/libiwinfo/description
   Wireless information library with consistent interface for proprietary Broadcom,
-  madwifi, nl80211 and wext driver interfaces.
+  nl80211 and wext driver interfaces.
 endef
 
 
@@ -77,7 +75,6 @@ IWINFO_BACKENDS := \
        $(if $(CONFIG_PACKAGE_kmod-brcm-wl),wl) \
        $(if $(CONFIG_PACKAGE_kmod-brcm-wl-mini),wl) \
        $(if $(CONFIG_PACKAGE_kmod-brcm-wl-mimo),wl) \
-       $(if $(CONFIG_PACKAGE_kmod-madwifi),madwifi) \
        $(if $(CONFIG_PACKAGE_kmod-cfg80211),nl80211)
 
 TARGET_CFLAGS += \