treewide: replace nbd@openwrt.org with nbd@nbd.name
[openwrt/staging/yousong.git] / package / network / utils / iw / Makefile
index 92bf6c46192178cbb8a200c8bfb2ddcbdab33032..d17cbca0df391a287fb9d80a3d9c1ca1355c1774 100644 (file)
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iw
-PKG_VERSION:=3.15
+PKG_VERSION:=4.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=https://www.kernel.org/pub/software/network/iw
-PKG_MD5SUM:=3b77ad7ec44a865a3bb2ab6c1c463bba
+PKG_SOURCE_URL:=@KERNEL/software/network/iw
+PKG_MD5SUM:=7adec72e91ebdd9c55429fa34a23a6f5
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,7 +25,7 @@ define Package/iw
   CATEGORY:=Network
   TITLE:=cfg80211 interface configuration utility
   URL:=http://wireless.kernel.org/en/users/Documentation/iw
-  DEPENDS:= +libnl-tiny @(!TARGET_avr32||BROKEN)
+  DEPENDS:= +libnl-tiny
 endef
 
 define Build/Configure