build: use mkhash to replace various quirky md5sum/openssl calls
[openwrt/staging/yousong.git] / package / network / utils / iptables / Makefile
index ee7ec476cf08b05684207d5f4505f55f554ea170..ac869f038532b5363c0f3218934a42d32e3eb861 100644 (file)
@@ -28,7 +28,7 @@ include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
   include $(INCLUDE_DIR)/netfilter.mk
-  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep 'NETFILTER' $(LINUX_DIR)/.config | md5s)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep 'NETFILTER' $(LINUX_DIR)/.config | mkhash md5)
 endif