build: consistently use 'depends on' instead of 'depends'
[openwrt/staging/dedeckeh.git] / package / network / services / samba36 / Makefile
index d6b2b506e676e7241a101f9846dd245c89e54229..2644f7d565563fb31ab4d6ccc0aa8aff840f9da0 100644 (file)
@@ -8,13 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=3.6.5
+PKG_VERSION:=3.6.11
 PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
        http://ftp.samba.org/pub/samba/old-versions
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=2f0c14547333c1b48fd4728b031e7040
+PKG_MD5SUM:=9039e0ab3e4fc632ff0a1a8f2433edb4
+
+PKG_LICENSE:=GPLv3
+PKG_LICENSE_FILES:=COPYING
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
@@ -46,7 +49,7 @@ endef
 define Package/samba36-server/config
        config PACKAGE_SAMBA_MAX_DEBUG_LEVEL
                int "Maximum level of compiled-in debug messages"
-               depends PACKAGE_samba36-server || PACKAGE_samba36-client
+               depends on PACKAGE_samba36-server || PACKAGE_samba36-client
                default -1
 
 endef