dropbear: honor CONFIG_TARGET_INIT_PATH
[openwrt/staging/jow.git] / package / network / services / dropbear / Makefile
index 5021c2aee16620ec4339b23184934952efcebad9..77104431db9092edd93a5327243b7e6750e7f75b 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=2020.81
+PKG_VERSION:=2022.83
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
-       http://matt.ucc.asn.au/dropbear/releases/ \
+       https://matt.ucc.asn.au/dropbear/releases/ \
        https://dropbear.nl/mirror/releases/
-PKG_HASH:=48235d10b37775dbda59341ac0c4b239b82ad6318c31568b985730c788aac53b
+PKG_HASH:=bc5a121ffbc94b5171ad5ebe01be42746d50aa797c9549a4639894a16749443b
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
@@ -23,7 +23,7 @@ PKG_CPE_ID:=cpe:/a:matt_johnston:dropbear_ssh_server
 
 PKG_BUILD_PARALLEL:=1
 PKG_ASLR_PIE_REGULAR:=1
-PKG_USE_MIPS16:=0
+PKG_BUILD_FLAGS:=no-mips16 gc-sections lto
 PKG_FIXUP:=autoreconf
 PKG_FLAGS:=nonshared
 
@@ -32,16 +32,17 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_DROPBEAR_CURVE25519 CONFIG_DROPBEAR_ZLIB \
        CONFIG_DROPBEAR_ED25519 CONFIG_DROPBEAR_CHACHA20POLY1305 \
        CONFIG_DROPBEAR_UTMP CONFIG_DROPBEAR_PUTUTLINE \
-       CONFIG_DROPBEAR_DBCLIENT CONFIG_DROPBEAR_SCP
+       CONFIG_DROPBEAR_DBCLIENT CONFIG_DROPBEAR_SCP CONFIG_DROPBEAR_ASKPASS \
+       CONFIG_DROPBEAR_DBCLIENT_AGENTFORWARD CONFIG_DROPBEAR_AGENTFORWARD
 
 include $(INCLUDE_DIR)/package.mk
 
 ifneq ($(DUMP),1)
-  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell echo $(CONFIG_TARGET_INIT_PATH) | mkhash md5)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell echo $(CONFIG_TARGET_INIT_PATH) | $(MKHASH) md5)
 endif
 
 define Package/dropbear/Default
-  URL:=http://matt.ucc.asn.au/dropbear/
+  URL:=https://matt.ucc.asn.au/dropbear/
 endef
 
 define Package/dropbear/config
@@ -98,77 +99,91 @@ CONFIGURE_ARGS += \
 
 ##############################################################################
 #
-#   option|value - add option to localoptions.h
-# !!option|value - replace option in sysoptions.h
+#   option,value - add option to localoptions.h
+# !!option,value - replace option in sysoptions.h
 #
 ##############################################################################
 
 # remove protocol idented software version number:
 # - LOCAL_IDENT
 # disable legacy/unsafe methods and unused functionality:
-# - INETD_MODE
 # - DROPBEAR_CLI_NETCAT
 # - DROPBEAR_DSS
 # - DO_MOTD
+# - DROPBEAR_DH_GROUP14_SHA1
+# - DROPBEAR_SHA1_HMAC
 DB_OPT_COMMON = \
-       DEFAULT_PATH|"$(TARGET_INIT_PATH)" \
-       !!LOCAL_IDENT|"SSH-2.0-dropbear" \
-       INETD_MODE|0 \
-       DROPBEAR_CLI_NETCAT|0 \
-       DROPBEAR_DSS|0 \
-       DO_MOTD|0 \
+       !!LOCAL_IDENT,"SSH-2.0-dropbear" \
+       DEFAULT_PATH,"$(TARGET_INIT_PATH)" \
+       DEFAULT_ROOT_PATH,"$(TARGET_INIT_PATH)" \
+       DROPBEAR_DSS,0 \
+       DROPBEAR_CLI_NETCAT,0 \
+       DO_MOTD,0 \
+       DROPBEAR_DH_GROUP14_SHA1,0 \
+       DROPBEAR_SHA1_HMAC,0 \
 
 
 ##############################################################################
 #
-#   option|config|enabled|disabled = add option to localoptions.h
-# !!option|config|enabled|disabled = replace option in sysoptions.h
+#   option,config,enabled,disabled = add option to localoptions.h
+# !!option,config,enabled,disabled = replace option in sysoptions.h
 #
 #   option := (config) ? enabled : disabled
 #
 ##############################################################################
 
 DB_OPT_CONFIG = \
-       DROPBEAR_CURVE25519|CONFIG_DROPBEAR_CURVE25519|1|0 \
-       DROPBEAR_ED25519|CONFIG_DROPBEAR_ED25519|1|0 \
-       DROPBEAR_CHACHA20POLY1305|CONFIG_DROPBEAR_CHACHA20POLY1305|1|0 \
-       DROPBEAR_ECDSA|CONFIG_DROPBEAR_ECC|1|0 \
-       DROPBEAR_ECDH|CONFIG_DROPBEAR_ECC|1|0 \
-       !!DROPBEAR_ECC_384|CONFIG_DROPBEAR_ECC_FULL|1|0 \
-       !!DROPBEAR_ECC_521|CONFIG_DROPBEAR_ECC_FULL|1|0 \
+       !!DROPBEAR_ECC_384,CONFIG_DROPBEAR_ECC_FULL,1,0 \
+       !!DROPBEAR_ECC_521,CONFIG_DROPBEAR_ECC_FULL,1,0 \
+       DROPBEAR_CURVE25519,CONFIG_DROPBEAR_CURVE25519,1,0 \
+       DROPBEAR_CHACHA20POLY1305,CONFIG_DROPBEAR_CHACHA20POLY1305,1,0 \
+       DROPBEAR_ED25519,CONFIG_DROPBEAR_ED25519,1,0 \
+       DROPBEAR_SK_ED25519,CONFIG_DROPBEAR_ED25519,1,0 \
+       DROPBEAR_ECDSA,CONFIG_DROPBEAR_ECC,1,0 \
+       DROPBEAR_SK_ECDSA,CONFIG_DROPBEAR_ECC,1,0 \
+       DROPBEAR_ECDH,CONFIG_DROPBEAR_ECC,1,0 \
+       DROPBEAR_CLI_ASKPASS_HELPER,CONFIG_DROPBEAR_ASKPASS,1,0 \
+       DROPBEAR_CLI_AGENTFWD,CONFIG_DROPBEAR_DBCLIENT_AGENTFORWARD,1,0 \
+       DROPBEAR_SVR_AGENTFWD,CONFIG_DROPBEAR_AGENTFORWARD,1,0 \
 
 
-TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections -flto
-TARGET_LDFLAGS += -Wl,--gc-sections -flto=jobserver
+TARGET_CFLAGS += -DARGTYPE=3
+
+xsedx:=$(shell printf '\027')
 
 db_opt_add     =echo '\#define $(1) $(2)' >> $(PKG_BUILD_DIR)/localoptions.h
-db_opt_replace =$(ESED) 's,^(\#define $(1)) .*$$$$,\1 $(2),g' $(PKG_BUILD_DIR)/sysoptions.h
+db_opt_replace =$(ESED) '/^\#define $(1) .*$$$$/{h;:a;$$$$!n;/^\#.+$$$$/bb;/^$$$$/bb;H;ba;:b;x;s$(xsedx)^.+$$$$$(xsedx)\#define $(1) $(2)$(xsedx)p;x};p' -n $(PKG_BUILD_DIR)/sysoptions.h
 
 define Build/Configure/dropbear_headers
        $(strip $(foreach s,$(DB_OPT_COMMON), \
-         $(if $(filter !!%,$(word 1,$(subst |, ,$(s)))), \
-           $(call db_opt_replace,$(patsubst !!%,%,$(word 1,$(subst |, ,$(s)))),$(word 2,$(subst |, ,$(s)))), \
-           $(call db_opt_add,$(word 1,$(subst |, ,$(s))),$(word 2,$(subst |, ,$(s)))) \
+         $(if $(filter !!%,$(word 1,$(subst $(comma),$(space),$(s)))), \
+           $(call db_opt_replace,$(patsubst !!%,%,$(word 1,$(subst $(comma),$(space),$(s)))),$(subst $(space),$(comma),$(wordlist 2,$(words $(subst $(comma),$(space),$(s))),$(subst $(comma),$(space),$(s))))), \
+           $(call db_opt_add,$(word 1,$(subst $(comma),$(space),$(s))),$(subst $(space),$(comma),$(wordlist 2,$(words $(subst $(comma),$(space),$(s))),$(subst $(comma),$(space),$(s))))) \
          ) ; \
        ))
 
        $(strip $(foreach s,$(DB_OPT_CONFIG), \
-         $(if $(filter !!%,$(word 1,$(subst |, ,$(s)))), \
-           $(call db_opt_replace,$(patsubst !!%,%,$(word 1,$(subst |, ,$(s)))),$(if $($(word 2,$(subst |, ,$(s)))),$(word 3,$(subst |, ,$(s))),$(word 4,$(subst |, ,$(s))))), \
-           $(call db_opt_add,$(word 1,$(subst |, ,$(s))),$(if $($(word 2,$(subst |, ,$(s)))),$(word 3,$(subst |, ,$(s))),$(word 4,$(subst |, ,$(s))))) \
+         $(if $(filter !!%,$(word 1,$(subst $(comma),$(space),$(s)))), \
+           $(call db_opt_replace,$(patsubst !!%,%,$(word 1,$(subst $(comma),$(space),$(s)))),$(if $($(word 2,$(subst $(comma),$(space),$(s)))),$(word 3,$(subst $(comma),$(space),$(s))),$(word 4,$(subst $(comma),$(space),$(s))))), \
+           $(call db_opt_add,$(word 1,$(subst $(comma),$(space),$(s))),$(if $($(word 2,$(subst $(comma),$(space),$(s)))),$(word 3,$(subst $(comma),$(space),$(s))),$(word 4,$(subst $(comma),$(space),$(s))))) \
          ) ; \
        ))
 endef
 
-define Build/Configure
-       : > $(PKG_BUILD_DIR)/localoptions.h
+define Build/Configure/dropbear_objects
+       grep -ERZl -e '($(subst $(space),|,$(strip $(sort $(patsubst !!%,%,$(foreach s,$(DB_OPT_COMMON) $(DB_OPT_CONFIG),$(word 1,$(subst $(comma),$(space),$(s)))))))))' \
+       $(PKG_BUILD_DIR)/ | sed -zE 's/^(.+)\.[^.]+$$$$/\1.o/' | sort -uV | xargs -0 -r rm -fv || :
+endef
 
+define Build/Configure
+       rm -f $(PKG_BUILD_DIR)/localoptions.h
        $(Build/Configure/Default)
 
+       : > $(PKG_BUILD_DIR)/localoptions.h
        $(Build/Configure/dropbear_headers)
 
-       # Enforce rebuild of svr-chansession.c
-       rm -f $(PKG_BUILD_DIR)/svr-chansession.o
+       # Enforce rebuild of files depending on configured options
+       $(Build/Configure/dropbear_objects)
 
        # Rebuild them on config change
        +$(MAKE) -C $(PKG_BUILD_DIR)/libtomcrypt clean
@@ -178,10 +193,12 @@ endef
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
+               IGNORE_SPEED=1 \
                PROGRAMS="dropbear $(if $(CONFIG_DROPBEAR_DBCLIENT),dbclient,) dropbearkey $(if $(CONFIG_DROPBEAR_SCP),scp,)" \
                MULTI=1 SCPPROGRESS=1
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
+               IGNORE_SPEED=1 \
                PROGRAMS="dropbearconvert"
 endef