openssl: update to version 1.0.2l
[openwrt/staging/hauke.git] / package / libs / openssl / Makefile
index 9b6430234e0a5d8ecf5a82af09118a661c756d96..7707c1943190205cff59fe5271086483454bfa4f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_BASE:=1.0.2
-PKG_BUGFIX:=k
+PKG_BUGFIX:=l
 PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
@@ -18,12 +18,13 @@ PKG_BUILD_PARALLEL:=0
 
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.openssl.org/source/ \
-       ftp://ftp.openssl.org/source/ \
-       http://www.openssl.org/source/old/$(PKG_BASE)/ \
-       ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
-       ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_HASH:=6b3977c61f2aedf0f96367dcfb5c6e578cf37e7b8d913b4ecb6643c3cb88d8c0
+PKG_SOURCE_URL:= \
+       http://ftp.fi.muni.cz/pub/openssl/source/ \
+       http://ftp.linux.hr/pub/openssl/source/ \
+       http://gd.tuwien.ac.at/infosys/security/openssl/source/ \
+       http://www.openssl.org/source/ \
+       http://www.openssl.org/source/old/$(PKG_BASE)/
+PKG_HASH:=ce07195b659e75f4e1db43552860070061f156a98bb37b672b101ba6e3ddf30c
 
 PKG_LICENSE:=OpenSSL
 PKG_LICENSE_FILES:=LICENSE
@@ -168,7 +169,7 @@ else
   endif
 endif
 
-STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(subst $(space),_,$(OPENSSL_OPTIONS))
+STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(shell echo $(OPENSSL_OPTIONS) | mkhash md5)
 
 define Build/Configure
        [ -f $(STAMP_CONFIGURED) ] || { \