kernel: usb: move phy-qcom-ipq806x-usb to ipq806x modules.mk
[openwrt/staging/jow.git] / package / kernel / linux / modules / usb.mk
index 5db02449680c441d49411eac6162a55f9304f3d8..fc411c5a542da0019732d201e5dae841cb8281ea 100644 (file)
@@ -70,24 +70,6 @@ endef
 $(eval $(call KernelPackage,usb-phy-nop))
 
 
-define KernelPackage/phy-qcom-ipq806x-usb
-  TITLE:=Qualcomm IPQ806x DWC3 USB PHY driver
-  DEPENDS:=@(TARGET_ipq40xx||TARGET_ipq806x)
-  KCONFIG:= CONFIG_PHY_QCOM_IPQ806X_USB
-  FILES:= \
-    $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-ipq806x-usb.ko
-  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-ipq806x-usb,1)
-  $(call AddDepends/usb)
-endef
-
-define KernelPackage/phy-qcom-ipq806x-usb/description
- This driver provides support for the integrated DesignWare
- USB3 IP Core within the QCOM SoCs.
-endef
-
-$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))
-
-
 define KernelPackage/phy-ath79-usb
   TITLE:=Support for ATH79 USB PHY
   KCONFIG:=CONFIG_PHY_AR7100_USB \