valgrind: update to 3.21.0
[openwrt/staging/nbd.git] / package / devel / valgrind / Makefile
index 04d06d91a6847db253bef4f3faedd60ac655dd56..f696b28c3c79e9eb5b087ee3b637c0acd3b8b6c8 100644 (file)
@@ -8,29 +8,32 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=valgrind
-PKG_VERSION:=3.11.0
+PKG_VERSION:=3.21.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://valgrind.org/downloads/
-PKG_MD5SUM:=6c396271a8c1ddd5a6fb9abe714ea1e8a86fce85b30ab26b4266aeb4c2413b42
+PKG_SOURCE_URL:=https://sourceware.org/pub/valgrind/
+PKG_HASH:=10ce1618bb3e33fad16eb79552b0a3e1211762448a0d7fce11c8a6243b9ac971
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=GPL-2.0+
+PKG_CPE_ID:=cpe:/a:valgrind:valgrind
 
 PKG_FIXUP = autoreconf
 PKG_INSTALL := 1
 PKG_BUILD_PARALLEL := 1
-PKG_USE_MIPS16:=0
+PKG_BUILD_FLAGS:=no-mips16
 PKG_SSP:=0
 
+STRIP:=:
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 define Package/valgrind
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=@mips||mipsel||i386||x86_64||powerpc||arm_v7 +libpthread +librt
+  DEPENDS:=@mips||mipsel||mips64||mips64el||i386||x86_64||powerpc||arm_v7||aarch64 +libpthread +librt
   TITLE:=debugging and profiling tools for Linux
   URL:=http://www.valgrind.org
 endef
@@ -84,7 +87,7 @@ CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(patsubst um,$(ARCH),$(LINUX
 CONFIGURE_VARS += \
        UNAME_R=$(LINUX_VERSION)
 
-ifeq ($(ARCH),x86_64)
+ifeq ($(CONFIG_ARCH_64BIT),y)
        CONFIGURE_ARGS += \
                --enable-only64bit
        BITS := 64bit
@@ -95,6 +98,7 @@ else
 endif
 
 CONFIGURE_ARGS += \
+       --enable-lto \
        --enable-tls \
        --without-x \
        --without-mpicc \
@@ -105,7 +109,7 @@ CONFIGURE_ARGS += \
        --without-included-gettext \
        --with-pagesize=4 \
 
-define Package/valgrind/install        
+define Package/valgrind/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/valgrind* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/valgrind
@@ -113,12 +117,21 @@ define Package/valgrind/install
                ./files/default.supp \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/none-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_core*.so \
-               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-core*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-linux*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/memcheck-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_memcheck*.so \
                $(1)/usr/lib/valgrind/
+
+ifneq ($(ARCH),aarch64)
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
+               $(1)/usr/lib/valgrind/
+endif
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/none-* \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/memcheck-*
 endef
 
 define Package/valgrind-cachegrind/install
@@ -128,6 +141,8 @@ define Package/valgrind-cachegrind/install
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/cachegrind-* \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/cachegrind-*
 endef
 
 define Package/valgrind-callgrind/install
@@ -137,6 +152,8 @@ define Package/valgrind-callgrind/install
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/callgrind-* \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/callgrind-*
 endef
 
 define Package/valgrind-drd/install
@@ -145,6 +162,8 @@ define Package/valgrind-drd/install
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/drd-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_drd*.so \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/drd-*
 endef
 
 define Package/valgrind-massif/install
@@ -155,6 +174,8 @@ define Package/valgrind-massif/install
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/massif-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_massif*.so \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/massif-*
 endef
 
 define Package/valgrind-helgrind/install
@@ -163,11 +184,14 @@ define Package/valgrind-helgrind/install
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/helgrind-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_helgrind*.so \
                $(1)/usr/lib/valgrind/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip -g",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/lib/valgrind/helgrind-*
 endef
 
 define Package/valgrind-vgdb/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vgdb $(1)/usr/bin/
+       $(patsubst STRIP=%,STRIP="$(TARGET_CROSS)strip",$(RSTRIP)) $(PKG_INSTALL_DIR)/usr/bin
 endef
 
 $(eval $(call BuildPackage,valgrind))