uboot-sunxi: bump to 2020.07
[openwrt/staging/stintel.git] / package / boot / uboot-sunxi / patches / 210-sunxi-deactivate-binman.patch
index b9cd9c7ac0084e5732ff56debe45e727dd6ce798..48ddf6d318dba26350b9e5088c55672007cdae83 100644 (file)
@@ -12,17 +12,26 @@ old way of generating images.
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1144,9 +1144,10 @@ u-boot-x86-16bit.bin: u-boot FORCE
- endif
+@@ -1607,8 +1607,10 @@ endif
  
  ifneq ($(CONFIG_ARCH_SUNXI),)
--u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb \
--              checkbinman FORCE
+ ifeq ($(CONFIG_ARM64),)
+-u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img u-boot.dtb FORCE
 -      $(call if_changed,binman)
 +OBJCOPYFLAGS_u-boot-sunxi-with-spl.bin = -I binary -O binary \
 +                              --pad-to=$(CONFIG_SPL_PAD_TO) --gap-fill=0xff
 +u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.img FORCE
 +      $(call if_changed,pad_cat)
- endif
+ else
+ u-boot-sunxi-with-spl.bin: spl/sunxi-spl.bin u-boot.itb FORCE
+       $(call if_changed,cat)
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -995,7 +995,6 @@ config ARCH_SOCFPGA
  
- ifneq ($(CONFIG_TEGRA),)
+ config ARCH_SUNXI
+       bool "Support sunxi (Allwinner) SoCs"
+-      select BINMAN
+       select CMD_GPIO
+       select CMD_MMC if MMC
+       select CMD_USB if DISTRO_DEFAULTS