uboot-mediatek: add build for BPi-R4
[openwrt/staging/jow.git] / package / boot / uboot-mediatek / Makefile
index d0e59d10179a7920056ff67bc5700ae450574262..9b421d2999dd904f638e450858208a865f3b4cac 100644 (file)
@@ -5,6 +5,8 @@ PKG_VERSION:=2023.07.02
 PKG_HASH:=6b6a48581c14abb0f95bd87c1af4d740922406d7b801002a9f94727fdde021d5
 PKG_BUILD_DEPENDS:=!(TARGET_ramips||TARGET_mediatek_mt7623):arm-trusted-firmware-tools/host
 
+UBOOT_USE_INTREE_DTC:=1
+
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
@@ -73,6 +75,15 @@ define U-Boot/mt7621_nand_rfb
   UBOOT_IMAGE:=u-boot-mt7621.bin
 endef
 
+define U-Boot/mt7621_zbtlink_zbt-wg3526-16m
+  NAME:=Zbtlink ZBT-WG3526-16m
+  UBOOT_CONFIG:=mt7621_zbtlink_zbt-wg3526-16m
+  BUILD_DEVICES:=zbtlink_zbt-wg3526-16m
+  BUILD_TARGET:=ramips
+  BUILD_SUBTARGET:=mt7621
+  UBOOT_IMAGE:=u-boot-mt7621.bin
+endef
+
 define U-Boot/mt7622_rfb1
   NAME:=MT7622 Reference Board 1
   UBOOT_CONFIG:=mt7622_rfb
@@ -184,7 +195,7 @@ define U-Boot/mt7628_rfb
   UBOOT_IMAGE:=u-boot-with-spl.bin
 endef
 
-define U-Boot/ravpower_rp-wd009
+define U-Boot/mt7628_ravpower_rp-wd009
   NAME:=RAVPower RP-WD009
   BUILD_TARGET:=ramips
   BUILD_DEVICES:=ravpower_rp-wd009
@@ -320,6 +331,18 @@ define U-Boot/mt7981_qihoo_360t7
   DEPENDS:=+trusted-firmware-a-mt7981-spim-nand-ddr3
 endef
 
+define U-Boot/mt7981_xiaomi_mi-router-ax3000t
+  NAME:=Xiaomi Router AX3000T
+  BUILD_SUBTARGET:=filogic
+  BUILD_DEVICES:=xiaomi_mi-router-ax3000t-ubootmod
+  UBOOT_CONFIG:=mt7981_xiaomi_mi-router-ax3000t
+  UBOOT_IMAGE:=u-boot.fip
+  BL2_BOOTDEV:=spim-nand
+  BL2_SOC:=mt7981
+  BL2_DDRTYPE:=ddr3
+  DEPENDS:=+trusted-firmware-a-mt7981-spim-nand-ddr3
+endef
+
 define U-Boot/mt7981_xiaomi_mi-router-wr30u
   NAME:=Xiaomi Router WR30U
   BUILD_SUBTARGET:=filogic
@@ -405,6 +428,18 @@ define U-Boot/mt7986_glinet_gl-mt6000
   DEPENDS:=+trusted-firmware-a-mt7986-emmc-ddr4
 endef
 
+define U-Boot/mt7986_jdcloud_re-cp-03
+  NAME:=JDCloud RE-CP-03
+  BUILD_SUBTARGET:=filogic
+  BUILD_DEVICES:=jdcloud_re-cp-03
+  UBOOT_CONFIG:=mt7986a_jdcloud_re-cp-03
+  UBOOT_IMAGE:=u-boot.fip
+  BL2_BOOTDEV:=emmc
+  BL2_SOC:=mt7986
+  BL2_DDRTYPE:=ddr4
+  DEPENDS:=+trusted-firmware-a-mt7986-emmc-ddr4
+endef
+
 define U-Boot/mt7986_tplink_tl-xdr4288
   NAME:=TP-LINK TL-XDR4288
   BUILD_SUBTARGET:=filogic
@@ -465,6 +500,42 @@ define U-Boot/mt7986_zyxel_ex5601-t0
   DEPENDS:=+trusted-firmware-a-mt7986-spim-nand-4k-ddr4
 endef
 
+define U-Boot/mt7988_bananapi_bpi-r4-emmc
+  NAME:=BananaPi BPi-R4
+  BUILD_SUBTARGET:=filogic
+  BUILD_DEVICES:=bananapi_bpi-r4
+  UBOOT_CONFIG:=mt7988a_bananapi_bpi-r4-emmc
+  UBOOT_IMAGE:=u-boot.fip
+  BL2_BOOTDEV:=emmc
+  BL2_SOC:=mt7988
+  BL2_DDRTYPE:=comb
+  DEPENDS:=+trusted-firmware-a-mt7988-emmc-comb
+endef
+
+define U-Boot/mt7988_bananapi_bpi-r4-sdmmc
+  NAME:=BananaPi BPi-R4
+  BUILD_SUBTARGET:=filogic
+  BUILD_DEVICES:=bananapi_bpi-r4
+  UBOOT_CONFIG:=mt7988a_bananapi_bpi-r4-sdmmc
+  UBOOT_IMAGE:=u-boot.fip
+  BL2_BOOTDEV:=sdmmc
+  BL2_SOC:=mt7988
+  BL2_DDRTYPE:=comb
+  DEPENDS:=+trusted-firmware-a-mt7988-sdmmc-comb
+endef
+
+define U-Boot/mt7988_bananapi_bpi-r4-snand
+  NAME:=BananaPi BPi-R4
+  BUILD_SUBTARGET:=filogic
+  BUILD_DEVICES:=bananapi_bpi-r4
+  UBOOT_CONFIG:=mt7988a_bananapi_bpi-r4-snand
+  UBOOT_IMAGE:=u-boot.fip
+  BL2_BOOTDEV:=spim-nand-ubi
+  BL2_SOC:=mt7988
+  BL2_DDRTYPE:=comb
+  DEPENDS:=+trusted-firmware-a-mt7988-spim-nand-ubi-comb
+endef
+
 define U-Boot/mt7988_rfb-spim-nand
   NAME:=MT7988 Reference Board
   BUILD_SUBTARGET:=filogic
@@ -531,6 +602,7 @@ UBOOT_TARGETS := \
        mt7620_rfb \
        mt7621_nand_rfb \
        mt7621_rfb \
+       mt7621_zbtlink_zbt-wg3526-16m \
        mt7622_bananapi_bpi-r64-emmc \
        mt7622_bananapi_bpi-r64-sdmmc \
        mt7622_bananapi_bpi-r64-snand \
@@ -542,7 +614,7 @@ UBOOT_TARGETS := \
        mt7623n_bpir2 \
        mt7623a_unielec_u7623 \
        mt7628_rfb \
-       ravpower_rp-wd009 \
+       mt7628_ravpower_rp-wd009 \
        mt7629_rfb \
        mt7981_cmcc_rax3000m-emmc \
        mt7981_cmcc_rax3000m-nand \
@@ -554,18 +626,23 @@ UBOOT_TARGETS := \
        mt7981_rfb-sd \
        mt7981_rfb-snfi \
        mt7981_qihoo_360t7 \
+       mt7981_xiaomi_mi-router-ax3000t \
        mt7981_xiaomi_mi-router-wr30u \
        mt7986_bananapi_bpi-r3-emmc \
        mt7986_bananapi_bpi-r3-sdmmc \
        mt7986_bananapi_bpi-r3-snand \
        mt7986_bananapi_bpi-r3-nor \
        mt7986_glinet_gl-mt6000 \
+       mt7986_jdcloud_re-cp-03 \
        mt7986_tplink_tl-xdr4288 \
        mt7986_tplink_tl-xdr6086 \
        mt7986_tplink_tl-xdr6088 \
        mt7986_xiaomi_redmi-router-ax6000 \
        mt7986_zyxel_ex5601-t0 \
        mt7986_rfb \
+       mt7988_bananapi_bpi-r4-emmc \
+       mt7988_bananapi_bpi-r4-sdmmc \
+       mt7988_bananapi_bpi-r4-snand \
        mt7988_rfb-spim-nand \
        mt7988_rfb-snand \
        mt7988_rfb-nor \