layerscape: add FRWY-LS1046A board support
[openwrt/staging/mkresin.git] / package / boot / uboot-layerscape / Makefile
index 1cc746f9a68058ea837cb89e2969918ec0af25e7..98b129f0ff1882bcf8a091c18a48c3ad634250e7 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-layerscape
-PKG_VERSION:=LSDK-20.04
-PKG_RELEASE:=1
+PKG_VERSION:=LSDK-20.04-update-290520
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://source.codeaurora.org/external/qoriq/qoriq-components/u-boot
-PKG_SOURCE_VERSION:=b0833bd0e26c059277f0673c9887b967f1ea5837
-PKG_MIRROR_HASH:=3cc01d4853ba56d9bcfe5366eddb5f664ae110741146d04f03434d38b4b5b0a0
+PKG_SOURCE_VERSION:=1e55b2f9e7f56b76569089b9e950f49c1579580e
+PKG_MIRROR_HASH:=46aace27e1367f40b424a64215d524a99c3bd62f49057550039e72d5a1ab7edb
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
@@ -27,67 +27,77 @@ define U-Boot/Default
   ENV_SIZE:=0x2000
 endef
 
-define U-Boot/ls1012afrdm
+define U-Boot/fsl_ls1012a-frdm
   NAME:=NXP LS1012AFRDM
   UBOOT_CONFIG:=ls1012afrdm_tfa
   ENV_SIZE:=0x40000
 endef
 
-define U-Boot/ls1012ardb
+define U-Boot/fsl_ls1012a-rdb
   NAME:=NXP LS1012ARDB
   UBOOT_CONFIG:=ls1012ardb_tfa
   ENV_SIZE:=0x40000
 endef
 
-define U-Boot/ls1012afrwy
+define U-Boot/fsl_ls1012a-frwy-sdboot
   NAME:=NXP LS1012AFRWY
   UBOOT_CONFIG:=ls1012afrwy_tfa
   ENV_SIZE:=0x10000
 endef
 
-define U-Boot/ls1043ardb
+define U-Boot/fsl_ls1043a-rdb
   NAME:=NXP LS1043ARDB
   UBOOT_CONFIG:=ls1043ardb_tfa
 endef
 
-define U-Boot/ls1043ardb-sdboot
+define U-Boot/fsl_ls1043a-rdb-sdboot
   NAME:=NXP LS1043ARDB SD Card Boot
   UBOOT_CONFIG:=ls1043ardb_tfa
 endef
 
-define U-Boot/ls1046ardb
+define U-Boot/fsl_ls1046a-frwy
+  NAME:=NXP LS1046AFRWY
+  UBOOT_CONFIG:=ls1046afrwy_tfa
+endef
+
+define U-Boot/fsl_ls1046a-frwy-sdboot
+  NAME:=NXP LS1046AFRWY SD Card Boot
+  UBOOT_CONFIG:=ls1046afrwy_tfa
+endef
+
+define U-Boot/fsl_ls1046a-rdb
   NAME:=NXP LS1046ARDB
   UBOOT_CONFIG:=ls1046ardb_tfa
 endef
 
-define U-Boot/ls1046ardb-sdboot
+define U-Boot/fsl_ls1046a-rdb-sdboot
   NAME:=NXP LS1046ARDB SD Card Boot
   UBOOT_CONFIG:=ls1046ardb_tfa
 endef
 
-define U-Boot/ls1088ardb
+define U-Boot/fsl_ls1088a-rdb
   NAME:=NXP LS1088ARDB
   UBOOT_CONFIG:=ls1088ardb_tfa
 endef
 
-define U-Boot/ls1088ardb-sdboot
+define U-Boot/fsl_ls1088a-rdb-sdboot
   NAME:=NXP LS1088ARDB SD Card Boot
   UBOOT_CONFIG:=ls1088ardb_tfa
 endef
 
-define U-Boot/ls2088ardb
+define U-Boot/fsl_ls2088a-rdb
   NAME:=NXP LS2088ARDB
   UBOOT_CONFIG:=ls2088ardb_tfa
 endef
 
-define U-Boot/ls1021atwr
+define U-Boot/fsl_ls1021a-twr
   NAME:=NXP LS1021ATWR
   BUILD_SUBTARGET:=armv7
   UBOOT_CONFIG:=ls1021atwr_nor
   ENV_SIZE:=0x20000
 endef
 
-define U-Boot/ls1021atwr-sdboot
+define U-Boot/fsl_ls1021a-twr-sdboot
   NAME:=NXP LS1021ATWR SD Card Boot
   BUILD_SUBTARGET:=armv7
   UBOOT_CONFIG:=ls1021atwr_sdcard_ifc
@@ -95,7 +105,7 @@ define U-Boot/ls1021atwr-sdboot
   ENV_SIZE:=0x20000
 endef
 
-define U-Boot/ls1021aiot-sdboot
+define U-Boot/fsl_ls1021a-iot-sdboot
   NAME:=NXP LS1021AIOT SD Card Boot
   BUILD_SUBTARGET:=armv7
   UBOOT_CONFIG:=ls1021aiot_sdcard
@@ -104,19 +114,21 @@ define U-Boot/ls1021aiot-sdboot
 endef
 
 UBOOT_TARGETS := \
-  ls1012afrdm \
-  ls1012ardb \
-  ls1012afrwy \
-  ls1043ardb \
-  ls1043ardb-sdboot \
-  ls1046ardb \
-  ls1046ardb-sdboot \
-  ls1088ardb \
-  ls1088ardb-sdboot \
-  ls2088ardb \
-  ls1021atwr \
-  ls1021atwr-sdboot \
-  ls1021aiot-sdboot
+  fsl_ls1012a-frdm \
+  fsl_ls1012a-rdb \
+  fsl_ls1012a-frwy-sdboot \
+  fsl_ls1043a-rdb \
+  fsl_ls1043a-rdb-sdboot \
+  fsl_ls1046a-frwy \
+  fsl_ls1046a-frwy-sdboot \
+  fsl_ls1046a-rdb \
+  fsl_ls1046a-rdb-sdboot \
+  fsl_ls1088a-rdb \
+  fsl_ls1088a-rdb-sdboot \
+  fsl_ls2088a-rdb \
+  fsl_ls1021a-twr \
+  fsl_ls1021a-twr-sdboot \
+  fsl_ls1021a-iot-sdboot
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)