layerscape: update u-boot to LSDK-20.04
[openwrt/staging/hauke.git] / package / boot / uboot-layerscape / Makefile
index ef456bfc7eb7bd0440592ac0ada90ebf74acec4c..1cc746f9a68058ea837cb89e2969918ec0af25e7 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-layerscape
-PKG_VERSION:=lsdk-1806
+PKG_VERSION:=LSDK-20.04
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://source.codeaurora.org/external/qoriq/qoriq-components/u-boot
-PKG_SOURCE_VERSION:=b3f98d438eefd1b355efdec0b50af5813ff8d0e1
-PKG_MIRROR_HASH:=59e35957055658e7fdefb16b92f954356985a8191942d93f254861c75c47b32b
+PKG_SOURCE_VERSION:=b0833bd0e26c059277f0673c9887b967f1ea5837
+PKG_MIRROR_HASH:=3cc01d4853ba56d9bcfe5366eddb5f664ae110741146d04f03434d38b4b5b0a0
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
@@ -27,54 +27,57 @@ define U-Boot/Default
   ENV_SIZE:=0x2000
 endef
 
+define U-Boot/ls1012afrdm
+  NAME:=NXP LS1012AFRDM
+  UBOOT_CONFIG:=ls1012afrdm_tfa
+  ENV_SIZE:=0x40000
+endef
+
 define U-Boot/ls1012ardb
   NAME:=NXP LS1012ARDB
-  UBOOT_CONFIG:=ls1012ardb_qspi
+  UBOOT_CONFIG:=ls1012ardb_tfa
   ENV_SIZE:=0x40000
 endef
 
-define U-Boot/ls1012afrdm
-  NAME:=NXP LS1012AFRDM
-  UBOOT_CONFIG:=ls1012afrdm_qspi
-  ENV_SIZE:=0x40000
+define U-Boot/ls1012afrwy
+  NAME:=NXP LS1012AFRWY
+  UBOOT_CONFIG:=ls1012afrwy_tfa
+  ENV_SIZE:=0x10000
 endef
 
 define U-Boot/ls1043ardb
   NAME:=NXP LS1043ARDB
-  ENV_SIZE:=0x20000
+  UBOOT_CONFIG:=ls1043ardb_tfa
 endef
 
 define U-Boot/ls1043ardb-sdboot
   NAME:=NXP LS1043ARDB SD Card Boot
-  UBOOT_CONFIG:=ls1043ardb_sdcard
-  UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+  UBOOT_CONFIG:=ls1043ardb_tfa
 endef
 
 define U-Boot/ls1046ardb
   NAME:=NXP LS1046ARDB
-  UBOOT_CONFIG:=ls1046ardb_qspi
+  UBOOT_CONFIG:=ls1046ardb_tfa
 endef
 
 define U-Boot/ls1046ardb-sdboot
   NAME:=NXP LS1046ARDB SD Card Boot
-  UBOOT_CONFIG:=ls1046ardb_sdcard
-  UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+  UBOOT_CONFIG:=ls1046ardb_tfa
 endef
 
 define U-Boot/ls1088ardb
   NAME:=NXP LS1088ARDB
-  UBOOT_CONFIG:=ls1088ardb_qspi
+  UBOOT_CONFIG:=ls1088ardb_tfa
 endef
 
 define U-Boot/ls1088ardb-sdboot
   NAME:=NXP LS1088ARDB SD Card Boot
-  UBOOT_CONFIG:=ls1088ardb_sdcard_qspi
-  UBOOT_IMAGE:=u-boot-with-spl.bin
+  UBOOT_CONFIG:=ls1088ardb_tfa
 endef
 
 define U-Boot/ls2088ardb
   NAME:=NXP LS2088ARDB
-  UBOOT_CONFIG:=ls2080ardb
+  UBOOT_CONFIG:=ls2088ardb_tfa
 endef
 
 define U-Boot/ls1021atwr
@@ -92,9 +95,18 @@ define U-Boot/ls1021atwr-sdboot
   ENV_SIZE:=0x20000
 endef
 
+define U-Boot/ls1021aiot-sdboot
+  NAME:=NXP LS1021AIOT SD Card Boot
+  BUILD_SUBTARGET:=armv7
+  UBOOT_CONFIG:=ls1021aiot_sdcard
+  UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+  ENV_SIZE:=0x2000
+endef
+
 UBOOT_TARGETS := \
-  ls1012ardb \
   ls1012afrdm \
+  ls1012ardb \
+  ls1012afrwy \
   ls1043ardb \
   ls1043ardb-sdboot \
   ls1046ardb \
@@ -103,7 +115,8 @@ UBOOT_TARGETS := \
   ls1088ardb-sdboot \
   ls2088ardb \
   ls1021atwr \
-  ls1021atwr-sdboot
+  ls1021atwr-sdboot \
+  ls1021aiot-sdboot
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)