uboot-envtools: update to 2024.01
[openwrt/staging/jow.git] / package / boot / uboot-envtools / Makefile
index 8de6455b1e8ad03770bcdea7e65126f6badf6141..4ea93f9c791bb07c124a95226e22d3ac485f35f8 100644 (file)
@@ -9,15 +9,17 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
-PKG_VERSION:=2018.03
+PKG_VERSION:=2024.01
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=\
-       http://mirror2.openwrt.org/sources \
-       ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
+PKG_SOURCE_URL:= \
+    https://ftp.denx.de/pub/u-boot \
+    https://mirror.cyberbits.eu/u-boot \
+    ftp://ftp.denx.de/pub/u-boot
+PKG_HASH:=b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3
+PKG_SOURCE_SUBDIR:=$(PKG_DISTNAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_DISTNAME)-$(PKG_VERSION)
 
 PKG_BUILD_DEPENDS:=fstools
 
@@ -43,39 +45,42 @@ define Package/uboot-envtools/description
 endef
 
 define Build/Configure
-       touch $(PKG_BUILD_DIR)/include/config.h
-       mkdir -p $(PKG_BUILD_DIR)/include/config
-       touch $(PKG_BUILD_DIR)/include/config/auto.conf
-       mkdir -p $(PKG_BUILD_DIR)/include/generated
-       touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
+       $(call Build/Compile/Default,tools-only_defconfig)
 endef
 
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
-
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               TARGET_CFLAGS="$(TARGET_CFLAGS)" \
-               HOSTLDFLAGS= \
-               no-dot-config-targets=envtools \
-               envtools
+       $(call Build/Compile/Default,envtools)
 endef
 
+# We need to override the ARCH passed by buildsystem as otherwise the defconfig
+# for tools-only wont match and the includes for sandbox will be dropped
+MAKE_FLAGS += \
+       ARCH="sandbox" \
+       TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+       TARGET_LDFLAGS="$(TARGET_LDFLAGS)"
+
 define Package/uboot-envtools/conffiles
 /etc/config/ubootenv
 /etc/fw_env.config
+/etc/fw_sys.config
 endef
 
 define Package/uboot-envtools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/env/fw_printenv $(1)/usr/sbin
        $(LN) fw_printenv $(1)/usr/sbin/fw_setenv
+       $(INSTALL_BIN) ./files/fw_printsys $(1)/usr/sbin
+       $(INSTALL_BIN) ./files/fw_setsys $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/lib
        $(INSTALL_DATA) ./files/uboot-envtools.sh $(1)/lib
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(if $(wildcard ./files/$(BOARD)), \
-               $(INSTALL_DATA) ./files/$(BOARD) \
-               $(1)/etc/uci-defaults/30_uboot-envtools \
+       $(if $(wildcard ./files/$(BOARD)_$(SUBTARGET)), \
+               $(INSTALL_DATA) ./files/$(BOARD)_$(SUBTARGET) \
+               $(1)/etc/uci-defaults/30_uboot-envtools, \
+               $(if $(wildcard ./files/$(BOARD)), \
+                       $(INSTALL_DATA) ./files/$(BOARD) \
+                       $(1)/etc/uci-defaults/30_uboot-envtools \
+               ) \
        )
 endef