uboot-envtools: update to 2024.01
[openwrt/staging/jow.git] / package / boot / uboot-envtools / Makefile
index 8bc2c00ba5c257856c4b644c4a3a93a63db1304c..4ea93f9c791bb07c124a95226e22d3ac485f35f8 100644 (file)
@@ -9,15 +9,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
-PKG_VERSION:=2020.04
-PKG_RELEASE:=17
+PKG_VERSION:=2024.01
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
     https://ftp.denx.de/pub/u-boot \
     https://mirror.cyberbits.eu/u-boot \
     ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
+PKG_HASH:=b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3
 PKG_SOURCE_SUBDIR:=$(PKG_DISTNAME)-$(PKG_VERSION)
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_DISTNAME)-$(PKG_VERSION)
 
@@ -45,34 +45,42 @@ define Package/uboot-envtools/description
 endef
 
 define Build/Configure
-       touch $(PKG_BUILD_DIR)/include/config.h
-       mkdir -p $(PKG_BUILD_DIR)/include/config
-       touch $(PKG_BUILD_DIR)/include/config/auto.conf
-       mkdir -p $(PKG_BUILD_DIR)/include/generated
-       touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
+       $(call Build/Compile/Default,tools-only_defconfig)
 endef
 
+define Build/Compile
+       $(call Build/Compile/Default,envtools)
+endef
+
+# We need to override the ARCH passed by buildsystem as otherwise the defconfig
+# for tools-only wont match and the includes for sandbox will be dropped
 MAKE_FLAGS += \
+       ARCH="sandbox" \
        TARGET_CFLAGS="$(TARGET_CFLAGS)" \
-       TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
-       no-dot-config-targets=envtools \
-       envtools
+       TARGET_LDFLAGS="$(TARGET_LDFLAGS)"
 
 define Package/uboot-envtools/conffiles
 /etc/config/ubootenv
 /etc/fw_env.config
+/etc/fw_sys.config
 endef
 
 define Package/uboot-envtools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/env/fw_printenv $(1)/usr/sbin
        $(LN) fw_printenv $(1)/usr/sbin/fw_setenv
+       $(INSTALL_BIN) ./files/fw_printsys $(1)/usr/sbin
+       $(INSTALL_BIN) ./files/fw_setsys $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/lib
        $(INSTALL_DATA) ./files/uboot-envtools.sh $(1)/lib
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(if $(wildcard ./files/$(BOARD)), \
-               $(INSTALL_DATA) ./files/$(BOARD) \
-               $(1)/etc/uci-defaults/30_uboot-envtools \
+       $(if $(wildcard ./files/$(BOARD)_$(SUBTARGET)), \
+               $(INSTALL_DATA) ./files/$(BOARD)_$(SUBTARGET) \
+               $(1)/etc/uci-defaults/30_uboot-envtools, \
+               $(if $(wildcard ./files/$(BOARD)), \
+                       $(INSTALL_DATA) ./files/$(BOARD) \
+                       $(1)/etc/uci-defaults/30_uboot-envtools \
+               ) \
        )
 endef