uboot-envtools: update to 2024.01
[openwrt/staging/jow.git] / package / boot / uboot-envtools / Makefile
index 631032c247ad0f5153bb72cdc01c1f906c6eb25f..4ea93f9c791bb07c124a95226e22d3ac485f35f8 100644 (file)
@@ -9,23 +9,33 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
-PKG_VERSION:=2013.10
-PKG_RELEASE:=3
+PKG_VERSION:=2024.01
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
-       http://mirror2.openwrt.org/sources \
-       ftp://ftp.denx.de/pub/u-boot
+    https://ftp.denx.de/pub/u-boot \
+    https://mirror.cyberbits.eu/u-boot \
+    ftp://ftp.denx.de/pub/u-boot
+PKG_HASH:=b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3
+PKG_SOURCE_SUBDIR:=$(PKG_DISTNAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_DISTNAME)-$(PKG_VERSION)
 
-PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
+PKG_BUILD_DEPENDS:=fstools
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot-$(PKG_VERSION)
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
+PKG_FLAGS:=nonshared
+
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/uboot-envtools
   SECTION:=utils
   CATEGORY:=Utilities
+  SUBMENU:=Boot Loaders
   TITLE:=read/modify U-Boot bootloader environment
   URL:=http://www.denx.de/wiki/U-Boot
 endef
@@ -35,56 +45,43 @@ define Package/uboot-envtools/description
 endef
 
 define Build/Configure
+       $(call Build/Compile/Default,tools-only_defconfig)
 endef
 
 define Build/Compile
-       touch $(PKG_BUILD_DIR)/include/config.h
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               HOSTCC="$(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gcc" \
-               HOSTOPTFLAGS="$(TARGET_CFLAGS)" \
-               HOSTSTRIP="$(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)strip" \
-               env
+       $(call Build/Compile/Default,envtools)
 endef
 
+# We need to override the ARCH passed by buildsystem as otherwise the defconfig
+# for tools-only wont match and the includes for sandbox will be dropped
+MAKE_FLAGS += \
+       ARCH="sandbox" \
+       TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+       TARGET_LDFLAGS="$(TARGET_LDFLAGS)"
+
 define Package/uboot-envtools/conffiles
 /etc/config/ubootenv
 /etc/fw_env.config
+/etc/fw_sys.config
 endef
 
 define Package/uboot-envtools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/env/fw_printenv $(1)/usr/sbin
-       ln -s fw_printenv $(1)/usr/sbin/fw_setenv
+       $(LN) fw_printenv $(1)/usr/sbin/fw_setenv
+       $(INSTALL_BIN) ./files/fw_printsys $(1)/usr/sbin
+       $(INSTALL_BIN) ./files/fw_setsys $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/lib
        $(INSTALL_DATA) ./files/uboot-envtools.sh $(1)/lib
-ifneq ($(CONFIG_TARGET_ar71xx),)
-       $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_DATA) ./files/ar71xx $(1)/etc/uci-defaults/30_uboot-envtools
-endif
-ifneq ($(CONFIG_TARGET_cns3xxx),)
-       $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_DATA) ./files/cns3xxx $(1)/etc/uci-defaults/30_uboot-envtools
-endif
-ifneq ($(CONFIG_TARGET_imx6),)
-       $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_DATA) ./files/imx6 $(1)/etc/uci-defaults/30_uboot-envtools
-endif
-ifneq ($(CONFIG_TARGET_kirkwood),)
-       $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_DATA) ./files/kirkwood $(1)/etc/uci-defaults/30_uboot-envtools
-endif
-ifneq ($(CONFIG_TARGET_lantiq),)
-       $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_DATA) ./files/lantiq $(1)/etc/uci-defaults/30_uboot-envtools
-endif
-ifneq ($(CONFIG_TARGET_mxs),)
-       $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_BIN) ./files/mxs $(1)/etc/uci-defaults/30_uboot-envtools
-endif
-ifneq ($(CONFIG_TARGET_ramips),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_DATA) ./files/ramips $(1)/etc/uci-defaults/30_uboot-envtools
-endif
+       $(if $(wildcard ./files/$(BOARD)_$(SUBTARGET)), \
+               $(INSTALL_DATA) ./files/$(BOARD)_$(SUBTARGET) \
+               $(1)/etc/uci-defaults/30_uboot-envtools, \
+               $(if $(wildcard ./files/$(BOARD)), \
+                       $(INSTALL_DATA) ./files/$(BOARD) \
+                       $(1)/etc/uci-defaults/30_uboot-envtools \
+               ) \
+       )
 endef
 
 $(eval $(call BuildPackage,uboot-envtools))