build: add support to use the mold linker for packages
[openwrt/staging/hauke.git] / include / quilt.mk
index 00597ca0f2a67c83e62e82014104ea93bb371201..18cafe60a280bb1fccce96bb9bfff9954d284cb5 100644 (file)
@@ -116,7 +116,7 @@ define Quilt/RefreshDir
 endef
 
 define Quilt/Refresh/Host
-       $(call Quilt/RefreshDir,$(HOST_BUILD_DIR),$(PATCH_DIR))
+       $(call Quilt/RefreshDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR))
 endef
 
 define Quilt/Refresh/Package
@@ -159,7 +159,7 @@ define Quilt/Template
                false; \
        }
        @[ -n "$$$$(ls $(1)/patches/series)" -o \
-          "$$$$(cat $(1)/patches/series | mkhash md5)" = "$$(sort $(1)/patches/series | mkhash md5)" ] || { \
+          "$$$$(cat $(1)/patches/series | $(MKHASH) md5)" = "$$(sort $(1)/patches/series | $(MKHASH) md5)" ] || { \
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }