Revert "build: replace which with Bash command built-in"
[openwrt/staging/hauke.git] / include / prereq.mk
index c11178a884b4b450ee4fb585785a3ec1bb0cd998..23d5ded9b272b59e0c7700ed32ff4dd22b23dd22 100644 (file)
@@ -49,7 +49,7 @@ endef
 
 define RequireCommand
   define Require/$(1)
-    command -pv $(1)
+    which $(1)
   endef
 
   $$(eval $$(call Require,$(1),$(2)))
@@ -103,7 +103,7 @@ define SetupHostCommand
                   $(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
                if [ -n "$$$$$$$$cmd" ]; then \
                        bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
-                               command -pv "$$$$$$$${cmd%% *}")"; \
+                               which "$$$$$$$${cmd%% *}")"; \
                        if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
                                mkdir -p "$(STAGING_DIR_HOST)/bin"; \
                                ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \