include/prereq-build.mk: explicitly check for -f flag when using busybox time
[openwrt/staging/dedeckeh.git] / include / prereq-build.mk
index 72875aef4e67b0f20bf1ce63a770aacd9d0ad42e..edd63e9ee6821c80273756f423246f42fb5acc6d 100644 (file)
@@ -138,10 +138,10 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
 $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
        wget --version | grep GNU))
 
-$(eval $(call SetupHostCommand,time,Please install GNU 'time' or BusyBox 'time', \
+$(eval $(call SetupHostCommand,time,Please install GNU 'time' or BusyBox 'time' that supports -f, \
        gtime --version 2>&1 | grep GNU, \
        time --version 2>&1 | grep GNU, \
-       busybox time 2>&1 | grep BusyBox))
+       busybox time 2>&1 | grep -- '-f FMT'))
 
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))