opkg: update to latest Git HEAD
[openwrt/staging/rmilecki.git] / include / prereq-build.mk
index 0f2a35c93bbe39c78c2c17f2e332512af84a01f1..a711ae33f7edd9d5ec494fc4d0e0e6a363a7ed85 100644 (file)
@@ -105,9 +105,9 @@ $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
        gcp --help 2>&1 | grep 'Copy SOURCE', \
        cp --help 2>&1 | grep 'Copy SOURCE'))
 
-$(eval $(call SetupHostCommand,seq,, \
+$(eval $(call SetupHostCommand,seq,Please install seq, \
        gseq --version, \
-       seq --version))
+       seq --version 2>&1 | grep seq))
 
 $(eval $(call SetupHostCommand,awk,Please install GNU 'awk', \
        gawk --version 2>&1 | grep GNU, \
@@ -144,15 +144,17 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
 $(eval $(call CleanupPython2))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
-       python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
-       python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
-       python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+       python3.8 -V 2>&1 | grep 'Python 3', \
+       python3.7 -V 2>&1 | grep 'Python 3', \
+       python3.6 -V 2>&1 | grep 'Python 3', \
+       python3.5 -V 2>&1 | grep 'Python 3', \
        python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
-       python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
-       python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
-       python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+       python3.8 -V 2>&1 | grep 'Python 3', \
+       python3.7 -V 2>&1 | grep 'Python 3', \
+       python3.6 -V 2>&1 | grep 'Python 3', \
+       python3.5 -V 2>&1 | grep 'Python 3', \
        python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \