treewide: remove files for building 5.10 kernel
[openwrt/staging/stintel.git] / include / prereq-build.mk
index 7b345ebbaa41a70b7d260866a9a09f0192700013..14a221088050f53dd11127d1101a485d148bfe09 100644 (file)
@@ -8,6 +8,13 @@ include $(INCLUDE_DIR)/prereq.mk
 SHELL:=sh
 PKG_NAME:=Build dependency
 
+$(eval $(call TestHostCommand,true, \
+       Please install GNU 'coreutils', \
+       $(TRUE)))
+
+$(eval $(call TestHostCommand,false, \
+       Please install GNU 'coreutils', \
+       $(FALSE); [ $$$$$$$$? = 1 ] && $(TRUE)))
 
 # Required for the toolchain
 $(eval $(call TestHostCommand,working-make, \
@@ -204,17 +211,19 @@ $(eval $(call SetupHostCommand,which,Please install 'which', \
        /bin/which which, \
        which which))
 
-$(eval $(call RequireCHeader,argp.h, \
+ifeq ($(HOST_OS),Linux)
+  $(eval $(call RequireCHeader,argp.h, \
        Missing argp.h Please install the argp-standalone package if musl libc))
 
-$(eval $(call RequireCHeader,fts.h, \
+  $(eval $(call RequireCHeader,fts.h, \
        Missing fts.h Please install the musl-fts-dev package if musl libc))
 
-$(eval $(call RequireCHeader,obstack.h, \
+  $(eval $(call RequireCHeader,obstack.h, \
        Missing obstack.h Please install the musl-obstack-dev package if musl libc))
 
-$(eval $(call RequireCHeader,libintl.h, \
+  $(eval $(call RequireCHeader,libintl.h, \
        Missing libintl.h Please install the musl-libintl package if musl libc))
+endif
 
 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
        mkdir -p $(dir $@)