use autoreconf hook instead of manual call
[openwrt/openwrt.git] / include / package.mk
index abffa0c64cc3ef23b83e369165d861fa8237a6fd..64973b051066803e5bdc5690fa33ec4e352d0cc2 100644 (file)
@@ -76,6 +76,9 @@ ifeq ($(CONFIG_$(PKG_NAME)_USE_CUSTOM_SOURCE_DIR),y)
 PKG_SOURCE_URL:=
 # add hook to install a link to customer source path of dedicated package
 Hooks/Prepare/Pre += prepare_custom_source_directory
+ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
+  Hooks/Configure/Pre += autoreconf_target
+endif
 # define empty default action
 define Build/Prepare/Default
        @: