build: fix possible issue with kmod package having multiple AutoLoad's
[openwrt/staging/mkresin.git] / include / kernel.mk
index 7effca3832d66b82680cb4e652399ec7c3ceaf59..301f24be3e06606b6cc6010156acb7bee46194ac 100644 (file)
@@ -97,15 +97,16 @@ define ModuleAutoLoad
        $(SH_FUNC) \
        export modules=; \
        probe_module() { \
-               mods="$$$$$$$$1"; \
-               boot="$$$$$$$$2"; \
+               local mods="$$$$$$$$1"; \
+               local boot="$$$$$$$$2"; \
+               local mod; \
                shift 2; \
-               for mod in $(sort $$$$$$$$mods); do \
+               for mod in $$$$$$$$mods; do \
                        mkdir -p $(2)/etc/modules.d; \
                        echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
                done; \
                if [ -e $(2)/etc/modules.d/$(1) ]; then \
-                       if [ "$$$$$$$$boot" = "1" ]; then \
+                       if [ "$$$$$$$$boot" = "1" -a ! -e $(2)/etc/modules-boot.d/$(1) ]; then \
                                mkdir -p $(2)/etc/modules-boot.d; \
                                ln -s ../modules.d/$(1) $(2)/etc/modules-boot.d/; \
                        fi; \
@@ -113,16 +114,17 @@ define ModuleAutoLoad
                fi; \
        }; \
        add_module() { \
-               priority="$$$$$$$$1"; \
-               mods="$$$$$$$$2"; \
-               boot="$$$$$$$$3"; \
+               local priority="$$$$$$$$1"; \
+               local mods="$$$$$$$$2"; \
+               local boot="$$$$$$$$3"; \
+               local mod; \
                shift 3; \
-               for mod in $(sort $$$$$$$$mods); do \
+               for mod in $$$$$$$$mods; do \
                        mkdir -p $(2)/etc/modules.d; \
                        echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
                done; \
                if [ -e $(2)/etc/modules.d/$$$$$$$$priority-$(1) ]; then \
-                       if [ "$$$$$$$$boot" = "1" ]; then \
+                       if [ "$$$$$$$$boot" = "1" -a ! -e $(2)/etc/modules-boot.d/$$$$$$$$priority-$(1) ]; then \
                                mkdir -p $(2)/etc/modules-boot.d; \
                                ln -s ../modules.d/$$$$$$$$priority-$(1) $(2)/etc/modules-boot.d/; \
                        fi; \
@@ -131,6 +133,7 @@ define ModuleAutoLoad
        }; \
        $(3) \
        if [ -n "$$$$$$$$modules" ]; then \
+               modules="$$$$$$$$(echo "$$$$$$$$modules" | tr ' ' '\n' | sort | uniq | paste -s -d' ')"; \
                mkdir -p $(2)/etc/modules.d; \
                mkdir -p $(2)/CONTROL; \
                echo "#!/bin/sh" > $(2)/CONTROL/postinst-pkg; \