linux: mvebu: backport mvneta XDP support fixes
[openwrt/staging/luka.git] / include / kernel-build.mk
index 3fdf7efc52857a5184348cc1261848f75751b8a9..c371e78ab9b0b63bdd4de77cfa426ce0d3afbf9b 100644 (file)
@@ -162,9 +162,16 @@ define BuildKernel
        rm -f $(STAMP_CONFIGURED)
        $(LINUX_RECONF_CMD) > $(LINUX_DIR)/.config
        $(_SINGLE)$(KERNEL_MAKE) \
-               $(if $(findstring Darwin,$(HOST_OS)),HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses") \
+               $(if $(findstring Darwin,$(HOST_OS)), \
+                       HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses" \
+                       HOSTLDLIBS_mconf="-L$(STAGING_DIR_HOST)/lib -lncurses" \
+                       filechk_conf_cfg="      :" \
+               ) \
+               YACC=$(STAGING_DIR_HOST)/bin/bison \
                $$@
-       $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config > $(LINUX_RECONFIG_TARGET)
+       $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config | \
+               grep -vE '(CONFIG_CC_(HAS_ASM_GOTO|IS_GCC|IS_CLANG)|GCC_VERSION)=' \
+               > $(LINUX_RECONFIG_TARGET)
 
   install: $(LINUX_DIR)/.image
        +$(MAKE) -C image compile install TARGET_BUILD=