build: align SOURCE path for build system and SDK
[openwrt/openwrt.git] / include / image-commands.mk
index 9ce97b17cfa4ccd5adb979e41162733dc9949433..79a64f4bc13997d8121b8167cea6b82a04c45611 100644 (file)
@@ -138,11 +138,9 @@ UBI_NAND_SIZE_LIMIT = $(IMAGE_SIZE) - ($(NAND_SIZE)*20/1024 + 4*$(BLOCKSIZE))
 define Build/append-ubi
        sh $(TOPDIR)/scripts/ubinize-image.sh \
                $(if $(UBOOTENV_IN_UBI),--uboot-env) \
-               $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
-               $(if $(findstring fit,$(1)), \
-               $(if $(KERNEL_IN_UBI),--part fit=$(IMAGE_KERNEL)), \
                $(if $(KERNEL_IN_UBI),--kernel $(IMAGE_KERNEL)) \
-               --rootfs $(IMAGE_ROOTFS)) \
+               $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
+               --rootfs $(IMAGE_ROOTFS) \
                $@.tmp \
                -p $(BLOCKSIZE:%k=%KiB) -m $(PAGESIZE) \
                $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
@@ -154,6 +152,20 @@ define Build/append-ubi
                $(call Build/check-size,$(UBI_NAND_SIZE_LIMIT)))
 endef
 
+define Build/ubinize-image
+       sh $(TOPDIR)/scripts/ubinize-image.sh \
+               $(if $(UBOOTENV_IN_UBI),--uboot-env) \
+               $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
+               --part $(word 1,$(1))="$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(word 2,$(1))" \
+               $@.tmp \
+               -p $(BLOCKSIZE:%k=%KiB) -m $(PAGESIZE) \
+               $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
+               $(if $(VID_HDR_OFFSET),-O $(VID_HDR_OFFSET)) \
+               $(UBINIZE_OPTS)
+       cat $@.tmp >> $@
+       rm $@.tmp
+endef
+
 define Build/ubinize-kernel
        cp $@ $@.tmp
        sh $(TOPDIR)/scripts/ubinize-image.sh \