build: move append-string to image-commands.mk
[openwrt/staging/hauke.git] / include / image-commands.mk
index 63539bad0808c01fed3811f70b3857a33385c346..49138a216d5242710f0fe22af91c08cc1ff37142 100644 (file)
@@ -102,6 +102,10 @@ define Build/append-squashfs-fakeroot-be
        cat $@.fakesquashfs >> $@
 endef
 
+define Build/append-string
+       echo -n $(1) >> $@
+endef
+
 # append a fake/empty uImage header, to fool bootloaders rootfs integrity check
 # for example
 define Build/append-uImage-fakehdr